功能介绍

公路坐标计算系统

欢迎你使用《公路坐标计算系统》,它是公路施工放样的好助手，可以帮你完成以前你用很大的精力和时间完成的计算。它可以帮你完成直线、圆曲线(两种模式)、缓和曲线(两种模式)的中桩和任意长度、任意角度边桩坐标的计算。

你现在使用的公路坐标计算系统是在多年的施工放样工作中总结出来的一个很有效的程序。它能在工作中给予很大的方便，使你能从繁琐的计算工作中解脱出来，你只要按要求将已知的几个数据输入即可，并大大的提高了计算精确性和准确性。操作简便、实用，适合采用坐标法放样，如具有全站仪和测距仪的测量放线工作，快速准确定位，很有推广价值。

坐标计算
直线坐标计算
圆曲线坐标计算
缓和曲线坐标计算
复曲线坐标计算
S型曲线坐标计算
路线辅助设计
曲线变更
 解析交会
交点计算
 平交路口
 高 程
工 具

本软件具有以下特点：

操作简便、快捷、方便：

各项功能操作都非常直观，易于上手。只要输入几个已知数据，并在成果输出的时候能将你输入的已知数据进行输出，要求你确认。它能使你在以后的工作中可以随时随地的检查和验算。

功能强大：

可以进行任意长度边桩坐标的计算，这大方便了施工的需要。特别在路基施工中，可以大大方便施工和减少测量放样工作量。如施工中进行曲线上的圆管涵，明涵，暗涵的开挖线，直接可以在边桩上进行距离的测量即可进行，省了不少的人力物力

成果丰富:

可以将计算成果进行保存，其格式只要适当修改即可与全站仪进行通信，大大方便我们的工作。并可将结果输出到WORD和EXCEL中。其中word生成逐桩坐标表和加桩坐标表，EXCEL还可生成曲线要素表。它们可以供你在使用时更加方便。

多种工具:

有测量放样的多种小工具可以提供你使用，这在实际施工中具有很大的方便性。


界面窗口



菜单栏

菜单栏可以便你很方便的使用软件，便软件的功能可以直观的表现出来。你可以在相应的菜单项下选择相应的功能。

工具栏

尽管菜单命令可以完成各种操作，其相应的快捷键也可以提高操作的效率，但是菜单命令的操作相对繁琐，快捷键有需要用户加以记忆，所以，有时候用起来还略嫌不便。而工具栏是一种图形化的操作界面，具有直观和快捷的特点，熟练掌握工具栏的使用后，工作效率将大有提高。
你可以选择前一项功能进行计算，如圆曲线前一项功能是直线的坐标计算
你可以选择后一项功能进行计算，如直线的后一项功能是圆曲线的坐标计算
直线坐标计算
圆曲线坐标计算。通过圆曲线的几个曲线要素进行计算
圆曲线坐标计算，通过ZY、JP、YZ进行计算
缓和曲线坐标计算，通过曲线的几个要素进行计算
缓和曲线坐标计算，通过ZH、JP、HZ进行计算
复曲线坐标计算
S型曲线坐标计算
高程计算
科学计算器
有关版权信息等
离开公路坐标计算系统

项目索引

位于软件左边的项目索引可以方便使你选择相应的计算功能，单击相应的相应的项目，可以进行所选功能的计算。

项目工作区
项目工作区是本软件功能实现的主要部分。所有的功能都是在这里实现的，您将在这里进行数据的输入与计算等所有的功能。


常见问题



Q：如果是我的硬盘进行格式化或重新安装系统后，注册申请码会改变吗？
A：本软件的注册源是你的硬盘，如果注册用户在系统升级或者系统重新安装后，不会出现要求您重新进行注册的情况，除非您更换了硬盘。更换硬盘后，请直接通过Email与我联系，我会依据新的注册申请码给你重新注册。但是超过一定的次数，我会考虑请您重新付一部分的注册费用！

Q: 怎样寻求技术支持 ？
A:
1、请联系 MessureSoft@163.com ，请你在来信中说明清楚您遇到的情况，如您使用的操作系统，机器配置等情况，并告诉我您的汇单号码,原先的注册申请码、注册码，注册时间，注册数量以便我进行查证，因此，请你保存好你的凭证，同时如果软件若有报错信息，请将此错误信息也一并寄回，附加截图效果更好。
2、QQ：39607719，有关使用中的疑问请您和我联系。
3、访问测量天地网站,你可以使用留言本和论坛提出问题，我会给您进行解答。

Q:软件是如何安装的？
A: 本软件不需要安装，直接就可以运行，请你将软件狗插在打印口上，安装狗的驱动后就可以使用了。

Q:怎样安装并口软件狗？
A:并口软件狗可安装在计算机的任一并口上。把计算机和打印机的电源关闭后，将并口软件狗外壳上印有COMPUTER字样的一端插入并口，拧紧螺丝保证可靠连接。如果需要连接打印机或其他并口外设，可将其数据线连接在并口软件狗后面。

Q:怎样处理软件狗中安装常见问题？
A：1 如果安装时出现蓝屏保护性错误（Windows 9x下），可能是您的系统中感染了病毒。请用杀毒软件杀毒后再进行安装。
2 在Windows NT/2000/XP操作系统下安装时应以具有系统管理员权限的身份登录。

Q：当打印机和软件狗冲突时，都有哪些可能？如何解决呢？
A:这种冲突只能发生于您使用并口软件狗的情况下。并口软件狗对于打印机及其它符合IEEE-1284并口标准的标准设备都是透明的，但在同时工作时有可能会引起冲突。在Win9X/ME/NT/2000/XP下，通过驱动程序管理并口软件狗和打印机共同工作。当打印机与并口软件狗相互影响使其中之一无法正常工作时，一般有以下几种可能： a. 打印机电源未开，打印机将并口电压降低至并口软件狗工作电压之下，此时并口软件狗无法正常工作。解决方法：对于此类打印机，只需将打印机电源打开或将打印机去掉即可使并口软件狗工作正常。
b. 打印机驱动程序是并口独占型驱动，此时并口软件狗无法正常工作。
解决方法：对于此类打印机只能尽量避免并口软件狗与打印机同时工作，或者将打印驱动程序去掉。
c．并口工作方式不适于并口软件狗或打印机共同工作解决方法：
一般来说，并口软件狗及打印机在normal并口方式下冲突的可能性最小，可调整并口工作方式至normal模式。
d．接触不良或并口中个别线已断
解决方法：由于并口软件狗和打印机用到了并口中不同的线，在此种情况下有可能会发生只有并口软件狗或打印机一个可以工作，而另一个无法工作。建议更换或维修并口。

Q：软件狗是否只在安装时才需插在相应的端口上？
A：不是。只要执行软件，软件狗都必须插在端口上。

Q:能否带电插拔软件狗？
A:要尽量避免带电插拔并口软件狗，否则会造成并口软件狗的损坏。因为并口存在一定电压（0至5V），并口软件狗就是依靠并口所提供的电压工作的。一旦带电插拔，可能造成并口软件狗中的电流瞬间多次通断，从而造成并口软件狗中芯片的损坏或并口损坏。 要尽量避免带电插拔并口软件狗。尤其是在并口软件狗的后边接了打印机且打印机的电源打开的情况下，绝对禁止插拔并口软件狗，因为这样很容易造成并口软件狗的损坏，并有可能损坏打印机或计算机的并口。当并口上和并口软件狗插在一起的其它设备正在工作时（例如打印机在后台打印），应当尽量避免使用软件。因为某些非规范并口设备没有考虑到和其它设备同时工作的问题，从而导致并口资源冲突。

Q:能讲下软件狗的技术规格吗？
A:
尺寸： 55×45×15mm
EEPROM存储容量： 100 bytes
工作电压： 2.5V-6V
写操作平均工作电流： 小于1mA
读操作平均工作电流： 小于0.2mA
可写次数： 1,000,000
可读次数： 无限
掉电保持时间： 100年


使用手册

★★★因测量事关重大，在使用前请认真核对，以确保你工程的高速优质！！！★★★

 坐标计算

1、直线
根据已知的起点桩号、起点和终点的坐标信息，进行直线路段范围内的各点坐标。

2、园曲线（两种方式）

根据已知的交点桩号、交点的坐标及方位角、转向角、曲线 半径等信息，进行园曲线路段范围内的各点坐标。
可进行任意变宽的边桩计算、任意加桩计算

3、缓和曲线(两种方式)
 根据已知的交点桩号、交点的坐标及方位角、转向角、曲线半径及缓和曲线长等信息，进行园曲线路段范围内的各点坐标。
特色：可进行任意变宽的边桩计算、任意加桩计算，并可同时提供极坐标法放样的数据，还可以为您输出一个极为形象的曲线图形。

4、复曲线
 根据已知的起点坐标、切线方位角、及变化的曲率半径、曲线的偏向等信息，计算复曲线的坐标。

5、S型曲线
 根据已知的起点坐标、路线方位角、及半径、曲线的偏向等信息，计算复曲线的坐标。

路线辅助设计

1、单交点非对称平曲线
2、外距控制单交点平曲线
3、支距控制单交点平曲线
4、切线长控制单交点平曲线、
5、双交点虚交点平曲线
6、切基线平曲线设计
7、复曲线设计
8、卵型曲线设计
9、S型曲设计
10、三点圆曲线设计
11、凸型曲线设计

曲线变更

1、变更曲线切线方向1
2、变更曲线切线方向2
3、改动外矢距
4、过定点
5、移动终点
6、终点不移动

解析交会

1、单三角形（角度交会）
2、侧方交会
3、测边交会
4、前方交会
5、后方交会

平交路口

1、丁形道平交口

高 程

1、高程

交点计算

1、点到直线
2、两直线交点坐标
3、直线与圆交点坐标

工 具

1、控制桩计算
2、极坐标放样计算
3、坐标正反算
4、三角形夹角
5、圆曲线要素计算
6、计算器
7、系统的记事本

说明：

“角度”的输入格式以度分秒格式表示，如"24.30286"表示24度30分28.6秒，计算结果中的角度也是同样。

“里程”的输入格式以米为单位，如："25400.36"，计算结果中里程是以"公里+米"格式表示，如："K25+400.36"。

提示 ：本软件中未处理断链，请使用中注意！


坐标计算



坐标计算

1、直线
根据已知的起点桩号、起点和终点的坐标信息，进行直线路段范围内的各点坐标。

2、园曲线（两种方式）

根据已知的交点桩号、交点的坐标及方位角、转向角、曲线 半径等信息，进行园曲线路段范围内的各点坐标。

3、缓和曲线(两种方式)
根据已知的交点桩号、交点的坐标及方位角、转向角、曲线半径及缓和曲线长等信息，进行园曲线路段范围内的各点坐标。

4、复曲线
根据已知的起点坐标、切线方位角、及变化的曲率半径、曲线的偏向等信息，计算复曲线的坐标。

5、S型曲线
根据已知的起点坐标、路线方位角、及半径、曲线的偏向等信息，计算复曲线的坐标。


直线坐标计算



直线坐标计算

一、适用：
用于任意直线路段的坐标计算, 支持任意长度、任意角度边桩的加桩计算。

二、中桩坐标计算已知数据的输入：
起点桩号：输入时将格式为化为米数，如示例中的起点桩号为K5+414.904，输入5414.904。 起点的坐标分别输入X，Y的值，不用多说了。
长度：你要输入的是计算直线坐标的总长度，单位为米，如示例中的长度是3543.215米。
方位角：将在这里输入的是计算直线的方位角，如193°46′10.2″输入时输193.46102。另如23°38′55″输入23.3855。
  计算米数：用于中桩间距长度的确定，你可以根据实际进行确定，如每个中桩间距可为10米、20米、25米这三个单选项和你自己定义的长度，如50米，100米或者说是2米之类的值。
三、边桩计算坐标计算已知数据的输入：
  起点桩号、长度、方位角、计算米数同前，你只要在边桩计算的选择框内选中后，选择边桩的方向左或右，并在请输入边桩距离对话框内输入离中线的距离后即可
四、计算和加点

   在你仔细核对后回车或单击"计算"按钮即可进行计算，在右侧的文本框内显示出计算结果。计算完成后，保存按鍵可见。

  加点计算：你在中桩计算完成后，加点按钮可见。你输入加点桩号即可进行加点计算，可以进行中桩的加点和边桩的加点。
中桩加点：直接在加点桩号内输入加入点的桩号，不要选择边桩计算，点击加点按钮就OK!

边桩加点：在加点桩号内输入加入点的桩号，选择边桩计算，并选择相应的边桩方向（左边桩还是右边桩），选择边桩计算和长度，即它离中桩的距离（斜距），如果不是正交，请在边桩与路线夹角内输入夹角的值（与路线顺时针方向），点击加点按钮进行计算。如计算与路线成110度20分，与中线的距离为10米的左边桩，在边桩与路线夹角输入110.20，在边桩的距离内输入10，并选择左边桩的按钮，点击加点进行计算。

(如与中线有一定的夹角请输入，本软件中默认与路线前进顺时针方向为正夹角，在不特殊说明的情况下夹度的输入将全部采用这种方式)。

五、保存

1）纯数据

在生成文件时，选择这项内容，数据的保存则尽可能少有其它内容，文件只要稍加修改即可与全站仪进行通信（请用全站仪附带的随机软件导入到全站仪,修改主要是指删除计算的输入信息）。

********************** 示例数据 *********************************
下面显示的是你输入的已知数据，用于你以后对数据的复查！您输入的已知数据：
您输入的起始桩号为：K5+414.9040
您输入的x坐标为：4377375.2660
您输入的y坐标为：580437.5940
您输入的距离为：3543.2150米
您输入的方位角为：193°46′10.20″

计算于2004年06月07日 17:38:32
===========================================
你可以将上面的数据全部删除！

点 号 X 坐标 Y 坐标
5414.9040 4377375.266 580437.594
5420.0000 4377370.316 580436.381
5440.0000 4377350.891 580431.621
5460.0000 4377331.466 580426.860
5480.0000 4377312.041 580422.100
5500.0000 4377292.616 580417.340

... ...

8940.0000 4373951.477 579598.563
8960.0000 4373932.052 579593.803
8958.1190 4373933.879 579594.250

********************* 数据结束 ********************************

2）文本表格

在保存的时输入要保存的文件名即可保存为文本文件。是以追加方式进行保存，不会破坏原文件的。其格式如下所示：

3）输入数据

你可以将你在软件内输入的数据进行保存，以供你以后使用时，不用重复输入，同时还可以检查到上次输入的数据内容是否正确（请不要修改它的内容）。

4）WORD文件

软件支持WORD 文件的输出，你可以将计算的结果输出到WORD当中，方便你再次利用结果和再次编辑。当然，前提是你的计算机内安装了OFFICE系统。

计算完成后，请你选取文件保存类型中的WORD文件选项后，单击保存，你可以到下面的提示。

在看完注意事项后，单击下一步。

请你在输入框内输入工程的名称，它将用于你输出文件中相关的信息。如果你不进行选择，会自动选择“工程名称：”这几个字，在生成WORD文件中，你可以在相应的地方进行修改。

单击完成按钮，就可以进行WORD文件的生成，软件先是调用WORD生成并打开指定的文件"逐桩坐标表.doc"，如果你进行了加桩计算，软件同时生成“加桩坐标表.doc”供你使用，所以如果你有相同名称的文件请你改名或是剪切到其它的地方。生成文件的时间它同你的计算机的性能和你计算的数据的多少有直接的关系。在生成表格时，请你稍等。请你在计算输出完成后，用“另存为”将你计算的结果进行保存。

5）EXCEL文件

软件支持EXCEL文件的输出，你可以将计算的结果输出到EXCEL当中，方便你再次利用结果和再次编辑。前提是你的计算机内安装了OFFICE系统。

计算完成后，请你选取文件保存类型中的EXCEL文件选项后，单击保存，你可以到看到和保存WORD文件一样的提示。在最后一步点击完成后，就可以完成EXCEL文件的输出。

说明：

“角度”的输入格式以度分秒格式表示，如"24.30286"表示24度30分28.6秒。

“里程”的输入格式以米为单位，如："25400.36"，计算结果中里程是以"公里+米"格式表示，如："K25+400.36"。


圆曲线坐标计算



圆曲线坐标计算

一、适用：
用于任意圆曲线路段的坐标计算, 支持任意长度、任意角度边桩的加桩计算。通过两种方式进行！一是通过交点法进行计算，二是通过给定的几个曲线要素进行计算。

二、中桩坐标计算已知数据的输入：

A)这种计算方式是通过已知起点的计算数据，起点的坐标，桩号，起始方位角，半径，转角值或圆曲线的长度已知的情况下进行计算(下图)。

ZY桩号：输入时将格式为化为米数。 ZY的坐标分别输入X，Y的值，不用多说了。
  半径：圆的半径，以米为单位。
  圆曲线的长度：你要输入的是计算曲线坐标的总长度，单位为米。
转角角度：在这你要输入圆曲线转向角的角度。注意：它和圆曲线的长度只能选择其中之一，强烈建议采用圆曲线长度进行输入，这是因为你输入角度在计算时已经是近似值，这在大半径计算时可以明显的比较出来。
  路线方位角：输入的是圆曲线起始的坐标方位角，
  计算米数：用于中桩间距长度的确定，你可以根据实际进行确定，如每个中桩间距可为10米、20米、25米这三个单选项和你自己定义的长度，如50米，100米或者说是2米之类的值。

B)下面的计算方式是在已知起点（ZY）,交点(JP)，终点(YZ)的坐标的方式下进行计算的。

ZY点坐标：分别输入ZY点的X，Y的值。
JP点坐标：分别输入JP点的X，Y的值。
JP点桩号：输入JP点桩号。
YZ点坐标：分别输入YZ点的X，Y的值。

三、边桩计算坐标计算已知数据的输入：
  起点桩号、长度、方位角、计算米数同前，你只要在边桩计算的选择框内选中后，选择边桩的方向左或右，并在请输入边桩距离对话框内输入离中线的距离后即可
四、计算和加点

   在你仔细核对后回车或单击"计算"按钮即可进行计算，在右侧的文本框内显示出计算结果。计算完成后，保存按鍵可见。

  加点计算：你在中桩计算完成后，加点按钮可见。你输入加点桩号即可进行加点计算，可以进行中桩的加点和边桩的加点。
中桩加点：直接在加点桩号内输入加入点的桩号，不要选择边桩计算，点击加点按钮就OK!

边桩加点：在加点桩号内输入加入点的桩号，选择边桩计算，并选择相应的边桩方向（左边桩还是右边桩），选择边桩计算和长度，即它离中桩的距离（斜距），如果不是正交，请在边桩与路线夹角内输入夹角的值（与路线顺时针方向），点击加点按钮进行计算。如计算与路线成110度20分，与中线的距离为10米的左边桩，在边桩与路线夹角输入110.20，在边桩的距离内输入10，并选择左边桩的按钮，点击加点进行计算。

(如与中线有一定的夹角请输入，本软件中默认与路线前进顺时针方向为正夹角，在不特殊说明的情况下夹度的输入将全部采用这种方式)。

五、保存

1）纯数据

在生成文件时，选择这项内容，数据的保存则尽可能少有其它内容，文件只要稍加修改即可与全站仪进行通信（请用全站仪附带的随机软件导入到全站仪,修改主要是指删除计算的输入信息）。

********************** 示例数据 *********************************
下面显示的是你输入的已知数据，用于你以后对数据的复查！您输入的已知数据：
您输入的ZY点的x坐标为：78517.8030
您输入的ZY点的y坐标为：81858.1940
您输入的JP点桩号为：K4+603.2420
您输入的JP点的x坐标为：78490.0330
您输入的JP点的y坐标为：80710.7780
您输入的YZ点的x坐标为：77375.2660
您输入的YZ点的y坐标为：80437.5940
==========================================
曲线要素：
半径：R=1500.0011 曲线长：L=1959.4150
转角:74°50′38.69″(左)
切线长：1147.7521
外矢距：388.7387 切曲差：336.0892

ZY(K3+455.4899) X：78517.8030 Y:81858.1940
QZ(K4+435.1974) X：78187.1101 Y:80954.4078
YZ(K5+414.9049) X：77375.2660 Y:80437.5940
==========================================

计算于2004年06月25日 13:12:13
===========================================
你可以将上面的数据全部删除！

点 号 X 坐标 Y 坐标
K3+455.4899 78517.803 81858.194
K3+460 78517.687 81853.685
K3+480 78517.010 81833.697
K3+500 78516.066 81813.719

... ...

K5+380 77409.068 80446.296
K5+400 77389.725 80441.213
K5+414.9049 77375.266 80437.594

********************* 数据结束 ********************************

2）文本表格

在保存的时输入要保存的文件名即可保存为文本文件。是以追加方式进行保存，不会破坏原文件的。其格式如下所示：

3）输入数据

你可以将你在软件内输入的数据进行保存，以供你以后使用时，不用重复输入，同时还可以检查到上次输入的数据内容是否正确（请不要修改它的内容）。

4）WORD文件

软件支持WORD 文件的输出，你可以将计算的结果输出到WORD当中，方便你再次利用结果和再次编辑。当然，前提是你的计算机内安装了OFFICE系统。

计算完成后，请你选取文件保存类型中的WORD文件选项后，单击保存，你可以到下面的提示。

在看完注意事项后，单击下一步。

请你在输入框内输入工程的名称，它将用于你输出文件中相关的信息。如果你不进行选择，会自动选择“工程名称：”这几个字，在生成WORD文件中，你可以在相应的地方进行修改。

单击完成按钮，就可以进行WORD文件的生成，软件先是调用WORD生成并打开指定的文件"逐桩坐标表.doc"，如果你进行了加桩计算，软件同时生成“加桩坐标表.doc”供你使用，所以如果你有相同名称的文件请你改名或是剪切到其它的地方。生成文件的时间它同你的计算机的性能和你计算的数据的多少有直接的关系。在生成表格时，请你稍等。请你在计算输出完成后，用“另存为”将你计算的结果进行保存。

5）EXCEL文件

软件支持EXCEL文件的输出，你可以将计算的结果输出到EXCEL当中，方便你再次利用结果和再次编辑。前提是你的计算机内安装了OFFICE系统。

计算完成后，请你选取文件保存类型中的EXCEL文件选项后，单击保存，你可以到看到和保存WORD文件一样的提示。在最后一步点击完成后，就可以完成EXCEL文件的输出。

说明：

“角度”的输入格式以度分秒格式表示，如"24.30286"表示24度30分28.6秒。

“里程”的输入格式以米为单位，如："25400.36"，计算结果中里程是以"公里+米"格式表示，如："K25+400.36"。


缓和曲线坐标计算



缓和曲线坐标计算

一、适用：
用于任意缓和曲线路段的坐标计算, 支持任意长度、任意角度边桩的加桩计算。通过两种方式进行！一是通过交点法进行计算，二是通过给定的几个曲线要素进行计算。

二、中桩坐标计算已知数据的输入：

A)这种计算方式是通过已知起点的计算数据，起点的坐标，桩号，起始方位角，半径，转角值或圆曲线的长度等已知的情况下进行计算(下图)。

ZH桩号：输入时将格式为化为米数.
ZH的坐标分别输入X，Y的值。
半径：圆的半径，以米为单位。
缓和曲线长：输入缓和曲线的缓和曲线段的长度。
圆曲线的长度：你要输入的是计算曲线中的圆曲线的长度，单位为米。
转向角角度：在这你要输入圆曲线转向角的角度
注意：它和缓和曲线的长度只能选择其中之一，强烈建议采用缓和曲线长度进行输入，这是因为你输入角度在计算时已经是近似值，这在大半径计算时可以明显的比较出来其差异。
路线方位角：输入的是缓和曲线起始的坐标方位角，
计算米数：用于中桩间距长度的确定，你可以根据实际进行确定，如每个中桩间距可为10米、20米、25米这三个单选项和你自己定义的长度，如50米，100米或者说是2米之类的值。

B)下面的计算方式是在已知起点（ZH）,交点(JP)，终点(HZ)的坐标、半径及缓和曲线长的方式下进行计算的。

ZH点坐标：分别输入ZY点的X，Y的值。
JP点坐标：分别输入JP点的X，Y的值。
JP点桩号：输入JP点桩号。
YH点坐标：分别输入YZ点的X，Y的值。
半径：圆的半径，以米为单位。
缓和曲线长：输入缓和曲线的缓和曲线段的长度

三、边桩计算坐标计算已知数据的输入：
  起点桩号、长度、方位角、计算米数同前，你只要在边桩计算的选择框内选中后，选择边桩的方向左或右，并在请输入边桩距离对话框内输入离中线的距离后即可

四、计算和加点

   在你仔细核对后回车或单击"计算"按钮即可进行计算，在右侧的文本框内显示出计算结果。计算完成后，保存按鍵可见。

  加点计算：你在中桩计算完成后，加点按钮可见。你输入加点桩号即可进行加点计算，可以进行中桩的加点和边桩的加点。
中桩加点：直接在加点桩号内输入加入点的桩号，不要选择边桩计算，点击加点按钮就OK!

边桩加点：在加点桩号内输入加入点的桩号，选择边桩计算，并选择相应的边桩方向（左边桩还是右边桩），选择边桩计算和长度，即它离中桩的距离（斜距），如果不是正交，请在边桩与路线夹角内输入夹角的值（与路线顺时针方向），点击加点按钮进行计算。如计算与路线成110度20分，与中线的距离为10米的左边桩，在边桩与路线夹角输入110.20，在边桩的距离内输入10，并选择左边桩的按钮，点击加点进行计算。

(如与中线有一定的夹角请输入，本软件中默认与路线前进顺时针方向为正夹角，在不特殊说明的情况下夹度的输入将全部采用这种方式)。

五、保存

1）纯数据

在生成文件时，选择这项内容，数据的保存则尽可能少有其它内容，文件只要稍加修改即可与全站仪进行通信（请用全站仪附带的随机软件导入到全站仪,修改主要是指删除计算的输入信息）。

********************* 示例数据1 *********************************

下面显示的是你输入的已知数据，用于你以后对数据的复查！您输入的已知数据：
您输入的ZH点桩号为：K12+262.0260
您输入的ZH点的x坐标为：70996.9660
您输入的ZH点的y坐标为：80096.3120
您输入的圆曲线的曲线长度为：513.8510米
您输入的曲线的缓和曲线的长度为：500.0000米
您输入的路线方位角为：161°10′28.00″
您输入的路线半径为：1200.0000

==========================================
曲线要素：
半径：1200.0000 曲线长：1513.8510
外矢距：125.1590 切曲差：72.0179

转角:48°24′28.15″(右) 切线长：792.9344
==========================================
ZH(K12+262.0260)X=70996.9660 Y=80096.3120
HY(K12+762.0260)X=70514.5935 Y=80224.1941
QZ(K13+18.9515)X=70258.1807 Y=80227.5744
YH(K13+275.8770)X=70006.9044 Y=80176.3968
HZ(K13+775.8770)X=69556.8756 Y=79960.7323

计算于2004年06月25日 13:46:58
===========================================
你可以将上面的数据全部删除！

点 号 X 坐标 Y 坐标
K12+262.0260 70996.966 80096.312
K12+280 70979.953 80102.110
K12+300 70961.018 80108.551

... ...

K13+740 69588.082 79978.433
K13+760 69570.684 79968.569
K13+775.8770 69556.876 79960.732
加点计算结果:
点号 夹角 X坐标 Y坐标
K13+000 90° 0′0.00″ 70277.062 80229.202
K13+000L20 90° 0′0.00″ 70275.502 80249.141
K13+000R20 90° 0′0.00″ 70278.622 80209.263
K13+200L20 75° 0′0.00″ 70080.231 80217.094
K13+200R20 75° 0′0.00″ 70079.549 80177.100

********************* 数据1结束 ********************************

********************** 示例数据2 *********************************

下面显示的是你输入的已知数据，用于你以后对数据的复查！您输入的已知数据：
您输入的ZH点的x坐标为：70996.9660
您输入的ZH点的y坐标为：80096.3120
您输入的JP点桩号为：K13+54.9610
您输入的JP点的x坐标为：70246.4490
您输入的JP点的y坐标为：80352.1820
您输入的HZ点的x坐标为：69556.8764
您输入的HZ点的y坐标为：79960.7322
==========================================
曲线要素：
半径：1200.0000 曲线长：1513.8500
外矢距：125.1588 切曲差：72.0177

转角:48°24′27.99″(右) 切线长：792.9338
==========================================
ZH(K12+262.0272)X=70996.9660 Y=80096.3120
HY(K12+762.0272)X=70514.5934 Y=80224.1938
QZ(K13+18.9522)X=70258.1811 Y=80227.5740
YH(K13+275.8772)X=70006.9052 Y=80176.3966
HZ(K13+775.8772)X=69556.8764 Y=79960.7322

计算于2004年06月25日 13:44:05
===========================================
你可以将上面的数据全部删除！

点 号 X 坐标 Y 坐标
K12+262.0272 70996.966 80096.312
K12+280 70979.954 80102.110
K12+300 70961.020 80108.551
K12+320 70942.077 80114.968

... ...

K13+740 69588.083 79978.433
K13+760 69570.685 79968.569
K13+775.8772 69556.876 79960.732
加点计算结果:
点号 夹角 X坐标 Y坐标
K13+000L20 90° 0′0.00″ 70275.503 80249.140
K13+000R20 90° 0′0.00″ 70278.623 80209.262
K13+000 90° 0′0.00″ 70277.063 80229.201
K13+500L20 75° 0′0.00″ 69795.776 80111.436
K13+500R20 75° 0′0.00″ 69803.373 80072.164

********************* 数据2结束 ********************************

2）文本表格

在保存的时输入要保存的文件名即可保存为文本文件。是以追加方式进行保存，不会破坏原文件的。其格式如下所示：

3）输入数据

你可以将你在软件内输入的数据进行保存，以供你以后使用时，不用重复输入，同时还可以检查到上次输入的数据内容是否正确（请不要修改它的内容）。

4）WORD文件

软件支持WORD 文件的输出，你可以将计算的结果输出到WORD当中，方便你再次利用结果和再次编辑。当然，前提是你的计算机内安装了OFFICE系统。

计算完成后，请你选取文件保存类型中的WORD文件选项后，单击保存，你可以到下面的提示。

在看完注意事项后，单击下一步。

请你在输入框内输入工程的名称，它将用于你输出文件中相关的信息。如果你不进行选择，会自动选择“工程名称：”这几个字，在生成WORD文件中，你可以在相应的地方进行修改。

单击完成按钮，就可以进行WORD文件的生成，软件先是调用WORD生成并打开指定的文件"逐桩坐标表.doc"，如果你进行了加桩计算，软件同时生成“加桩坐标表.doc”供你使用，所以如果你有相同名称的文件请你改名或是剪切到其它的地方。生成文件的时间它同你的计算机的性能和你计算的数据的多少有直接的关系。在生成表格时，请你稍等。请你在计算输出完成后，用“另存为”将你计算的结果进行保存。

5）EXCEL文件

软件支持EXCEL文件的输出，你可以将计算的结果输出到EXCEL当中，方便你再次利用结果和再次编辑。前提是你的计算机内安装了OFFICE系统。

计算完成后，请你选取文件保存类型中的EXCEL文件选项后，单击保存，你可以到看到和保存WORD文件一样的提示。在最后一步点击完成后，就可以完成EXCEL文件的输出。

说明：

“角度”的输入格式以度分秒格式表示，如"24.30286"表示24度30分28.6秒。

“里程”的输入格式以米为单位，如："25400.36"，计算结果中里程是以"公里+米"格式表示，如："K25+400.36"。


复曲线坐标计算



复曲线坐标计算

一、适用：
用于由两圆曲线构成的复曲线的坐标计算, 支持任意长度、任意角度边桩的加桩计算。

二、中桩坐标计算已知数据的输入：
ZY桩号：输入时将格式为化为米数。 坐标分别输入X，Y的值。
半径R1：第一个圆曲线上的半径，单位为米。
转角值β1：输入前圆曲线的转角值。
半径R2：第二个圆曲线上的半径，单位为米。
转角值β2：输入后圆曲线的转角值。
路线方位角：将在这里输入的是路线的起始方位角。
  计算米数：用于中桩间距长度的确定，你可以根据实际进行确定，如每个中桩间距可为10米、20米、25米这三个单选项和你自己定义的长度，如50米，100米或者说是2米之类的值。
三、边桩计算坐标计算已知数据的输入：
  起点桩号、长度、方位角、计算米数同前，你只要在边桩计算的选择框内选中后，选择边桩的方向左或右，并在请输入边桩距离对话框内输入离中线的距离后即可
四、计算和加点

   在你仔细核对后回车或单击"计算"按钮即可进行计算，在右侧的文本框内显示出计算结果。计算完成后，保存按鍵可见。

  加点计算：你在中桩计算完成后，加点按钮可见。你输入加点桩号即可进行加点计算，可以进行中桩的加点和边桩的加点。
中桩加点：直接在加点桩号内输入加入点的桩号，不要选择边桩计算，点击加点按钮就OK!

边桩加点：在加点桩号内输入加入点的桩号，选择边桩计算，并选择相应的边桩方向（左边桩还是右边桩），选择边桩计算和长度，即它离中桩的距离（斜距），如果不是正交，请在边桩与路线夹角内输入夹角的值（与路线顺时针方向），点击加点按钮进行计算。如计算与路线成110度20分，与中线的距离为10米的左边桩，在边桩与路线夹角输入110.20，在边桩的距离内输入10，并选择左边桩的按钮，点击加点进行计算。

(如与中线有一定的夹角请输入，本软件中默认与路线前进顺时针方向为正夹角，在不特殊说明的情况下夹度的输入将全部采用这种方式)。

五、保存

1）纯数据

在生成文件时，选择这项内容，数据的保存则尽可能少有其它内容，文件只要稍加修改即可与全站仪进行通信（请用全站仪附带的随机软件导入到全站仪,修改主要是指删除计算的输入信息）。

********************** 示例数据 *********************************

下面显示的是你输入的已知数据，用于你以后对数据的复查！您输入的已知数据：
您输入的ZY点桩号为：K3+455.4900
您输入的ZY点的x坐标为：4378517.8030
您输入的ZY点的y坐标为：581858.1940
您输入的圆曲线转角β1为：74°50′38.80″
您输入的圆曲线转角β2为：15° 0′0.00″
您输入的路线方位角为：268°36′49.00″
您输入的路线半径R1为：1500.000000
您输入的路线半径R2为：2000.000000
=========================================
曲线要素：

前圆曲线：
圆曲线半径R1：1500.000000
曲线长：1959.4142
转角β1：74°50′38.80″(左)
切线长T1：1147.7518
外矢距E1：388.7388
切曲差q1：336.0894

后圆曲线：
圆曲线半径R2：2000.000000
曲线长：523.5988
转角β2：15° 0′0.00″(左)
切线长T2：263.3050
外矢距E2：17.2579
切曲差q2：3.0112

ZY(K3+455.4900)X:4378517.8030 Y:581858.1940
GQ(K5+414.9042)X:4377375.2668 Y:580437.5944
YZ(K5+938.5030)X:4376856.2846 Y:580380.5778
==========================================

计算于2004年06月25日 15:13:04
===========================================
你可以将上面的数据全部删除！

点 号 X 坐标 Y 坐标
K3+455.4900 4378517.803 581858.194
K3+460 4378517.687 581853.685
K3+480 4378517.010 581833.697
K3+500 4378516.066 581813.720

... ...

K5+900 4376894.784 580380.122
K5+920 4376874.785 580380.266
K5+938.5030 4376856.285 580380.578

********************* 数据结束 ********************************

2）文本表格

在保存的时输入要保存的文件名即可保存为文本文件。是以追加方式进行保存，不会破坏原文件的。其格式如下所示：

3）输入数据

你可以将你在软件内输入的数据进行保存，以供你以后使用时，不用重复输入，同时还可以检查到上次输入的数据内容是否正确（请不要修改它的内容）。

4）WORD文件

软件支持WORD 文件的输出，你可以将计算的结果输出到WORD当中，方便你再次利用结果和再次编辑。当然，前提是你的计算机内安装了OFFICE系统。

计算完成后，请你选取文件保存类型中的WORD文件选项后，单击保存，你可以到下面的提示。

在看完注意事项后，单击下一步。

请你在输入框内输入工程的名称，它将用于你输出文件中相关的信息。如果你不进行选择，会自动选择“工程名称：”这几个字，在生成WORD文件中，你可以在相应的地方进行修改。

单击完成按钮，就可以进行WORD文件的生成，软件先是调用WORD生成并打开指定的文件"逐桩坐标表.doc"，如果你进行了加桩计算，软件同时生成“加桩坐标表.doc”供你使用，所以如果你有相同名称的文件请你改名或是剪切到其它的地方。生成文件的时间它同你的计算机的性能和你计算的数据的多少有直接的关系。在生成表格时，请你稍等。请你在计算输出完成后，用“另存为”将你计算的结果进行保存。

5）EXCEL文件

软件支持EXCEL文件的输出，你可以将计算的结果输出到EXCEL当中，方便你再次利用结果和再次编辑。前提是你的计算机内安装了OFFICE系统。

计算完成后，请你选取文件保存类型中的EXCEL文件选项后，单击保存，你可以到看到和保存WORD文件一样的提示。在最后一步点击完成后，就可以完成EXCEL文件的输出。

说明：

“角度”的输入格式以度分秒格式表示，如"24.30286"表示24度30分28.6秒。

“里程”的输入格式以米为单位，如："25400.36"，计算结果中里程是以"公里+米"格式表示，如："K25+400.36"。


S曲线坐标计算



S曲线坐标计算

一、适用：
用于由两缓和曲线构成的S曲线的坐标计算, 支持任意长度、任意角度边桩的加桩计算。

二、中桩坐标计算已知数据的输入：
起点桩号：输入时将格式为化为米数。 坐标分别输入X，Y的值。
路线方位角：将在这里输入的是路线的起始方位角。
半径Ra：第一个曲线上的半径，单位为米。
缓和曲线长Ls1：输入前曲线的缓和曲线长。
转角角Ja：输入前曲线的转角值。
半径Rb：第二个曲线上的半径，单位为米。
缓和曲线长Ls2：输入后曲线的缓和曲线长。
转角角Jb：输入后曲线的转角值。
计算米数：用于中桩间距长度的确定，你可以根据实际进行确定，如每个中桩间距可为10米、20米、25米这三个单选项和你自己定义的长度，如50米，100米或者说是2米之类的值。
三、边桩计算坐标计算已知数据的输入：
  起点桩号、长度、方位角、计算米数同前，你只要在边桩计算的选择框内选中后，选择边桩的方向左或右，并在请输入边桩距离对话框内输入离中线的距离后即可
四、计算和加点

   在你仔细核对后回车或单击"计算"按钮即可进行计算，在右侧的文本框内显示出计算结果。计算完成后，保存按鍵可见。

  加点计算：你在中桩计算完成后，加点按钮可见。你输入加点桩号即可进行加点计算，可以进行中桩的加点和边桩的加点。
中桩加点：直接在加点桩号内输入加入点的桩号，不要选择边桩计算，点击加点按钮就OK!

边桩加点：在加点桩号内输入加入点的桩号，选择边桩计算，并选择相应的边桩方向（左边桩还是右边桩），选择边桩计算和长度，即它离中桩的距离（斜距），如果不是正交，请在边桩与路线夹角内输入夹角的值（与路线顺时针方向），点击加点按钮进行计算。如计算与路线成110度20分，与中线的距离为10米的左边桩，在边桩与路线夹角输入110.20，在边桩的距离内输入10，并选择左边桩的按钮，点击加点进行计算。

(如与中线有一定的夹角请输入，本软件中默认与路线前进顺时针方向为正夹角，在不特殊说明的情况下夹度的输入将全部采用这种方式)。

五、保存

1）纯数据

在生成文件时，选择这项内容，数据的保存则尽可能少有其它内容，文件只要稍加修改即可与全站仪进行通信（请用全站仪附带的随机软件导入到全站仪,修改主要是指删除计算的输入信息）。

********************** 示例数据 *********************************

下面显示的是你输入的已知数据，用于你以后对数据的复查！您输入的已知数据：
您输入的起点桩号为:

您输入的起点的x坐标为:
4385480.2250
您输入的起点的y坐标为:
583200.9160
您输入的曲线转角Ja为:
17°20′13.60″
您输入的曲线转角Jb为:
18°19′37.70″
您输入的路线方位角为:
137° 6′34.40″
您输入的路线半径Ra为:
1148.4020
您输入的路线半径Rb为:
1127.8280
您输入的路线缓和曲线长Ls1为:
170.0000
您输入的路线缓和曲线长Ls2为:
170.0000
=========================================
S型曲线要素：

前曲线：
曲线半径R1：1148.402000
曲线长：517.4946
转角β1：17°20′13.60″(左)
切线长T1：260.2296
外矢距E1：14.3305
切曲差q1：84.9845

后曲线：
曲线半径Ra：1127.828000
曲线长：530.7571
转角Ja：17°20′13.60″(右)
切线长T2：267.0885
外矢距E2：15.6610
切曲差q2：84.9839

曲线要素点坐标：
K1449+182.2320
X:4385480.2250 Y:583200.9160
HY1(K1449+869.7266):
X:4385358.5951 Y:583319.6261
YH1(K1449+529.7266):
X:4385248.3550 Y:583458.5102
GQ(K1449+699.7266):
X:4385160.3475 Y:583603.9083
HY2(K1449+869.7266):
X:4385072.2752 Y:583749.2654
YH2(K1450+60.4837):
X:4384952.5364 Y:583897.4687
HZ2(K1450+230.4837):
X:4384828.9271 Y:584014.1142

计算于2004年06月25日 15:06:24
===========================================
你可以将上面的数据全部删除！

点 号 X 坐标 Y 坐标
K1449+182.2320 4385480.225 583200.916
K1449+200 4385467.210 583213.012
K1449+220 4385452.585 583226.655

... ...

K1450+180 4384866.428 583980.316
K1450+200 4384851.600 583993.738
K1450+220 4384836.730 584007.112
K1450+230.4837 4384828.927 584014.114

********************* 数据结束 ********************************

2）文本表格

在保存的时输入要保存的文件名即可保存为文本文件。是以追加方式进行保存，不会破坏原文件的。其格式如下所示：

3）输入数据

你可以将你在软件内输入的数据进行保存，以供你以后使用时，不用重复输入，同时还可以检查到上次输入的数据内容是否正确（请不要修改它的内容）。

4）WORD文件

软件支持WORD 文件的输出，你可以将计算的结果输出到WORD当中，方便你再次利用结果和再次编辑。当然，前提是你的计算机内安装了OFFICE系统。

计算完成后，请你选取文件保存类型中的WORD文件选项后，单击保存，你可以到下面的提示。

在看完注意事项后，单击下一步。

请你在输入框内输入工程的名称，它将用于你输出文件中相关的信息。如果你不进行选择，会自动选择“工程名称：”这几个字，在生成WORD文件中，你可以在相应的地方进行修改。

单击完成按钮，就可以进行WORD文件的生成，软件先是调用WORD生成并打开指定的文件"逐桩坐标表.doc"，如果你进行了加桩计算，软件同时生成“加桩坐标表.doc”供你使用，所以如果你有相同名称的文件请你改名或是剪切到其它的地方。生成文件的时间它同你的计算机的性能和你计算的数据的多少有直接的关系。在生成表格时，请你稍等。请你在计算输出完成后，用“另存为”将你计算的结果进行保存。

5）EXCEL文件

软件支持EXCEL文件的输出，你可以将计算的结果输出到EXCEL当中，方便你再次利用结果和再次编辑。前提是你的计算机内安装了OFFICE系统。

计算完成后，请你选取文件保存类型中的EXCEL文件选项后，单击保存，你可以到看到和保存WORD文件一样的提示。在最后一步点击完成后，就可以完成EXCEL文件的输出。

说明：

“角度”的输入格式以度分秒格式表示，如"24.30286"表示24度30分28.6秒。

“里程”的输入格式以米为单位，如："25400.36"，计算结果中里程是以"公里+米"格式表示，如："K25+400.36"。


辅助设计



辅助设计

由于在测量中存在的各种情况，可能会对现有的路线进行更改重新进行设计和路线的敷设。
单交点非对称基本型平曲线：因其前后的缓和曲线长不同，其前后侧面的曲线要素也不同。

确定圆曲线半径和缓和曲线长是平曲线设计的主要任务。考虑到地形、地物、设计标准信线形协调等要求，单交点平曲线根据不同情况可分别由外距E、切线长T及曲线上任一点的支距t0、y0进行控制。
外距控制单交点平曲线：根据你输入的路线偏角与控制的外距值进行计算曲线。如果你要拟定缓和曲线的长度请你选择并输入。在计算完成后，如果不满足规范要求，请您重新拟定。
支距控制单交点平曲线：根据实际的情况，可能会确保路线要通过一个定点，此时可通过实测支距值进行确定路线。根据你输入的路线偏角与控制用的支距值进行计算曲线。如果你要拟定缓和曲线的长度请你选择并输入。在计算完成后，如果不满足规范要求，请您重新拟定。
切线长控制单交点平曲线：根据你输入的路线偏角与控制的切线长的值进行计算曲线。如果你要拟定缓和曲线的长度请你选择并输入。在计算完成后，如果不满足规范要求，请您重新拟定。
当双交点平曲线不与基线边相切时，就构成了虚交形式的平曲线。你只要输入所测量的值，就可进行曲线的解算了。如果不满足规范要求，请您重新拟定。
切基线平曲线：线型如图所示，输入你测量的数据（偏角a、偏角b与基线边长AB）单击计算就可进行曲线的解算。如果不满足规范要求，请您重新拟定。
当两个半径不相等的非对称基本型平曲首尾相连时构成了复曲线。测设时，一般由先拟定约束条件较严格的一端的半径，求算另一端的曲线要素。结算完后，如果不满足规范要求，请您重新拟定。
卵型曲线：根据你输入的路线偏角与前后圆的半径和缓和曲线长值进行计算曲线。在计算完成后，如果不满足规范要求，请您重新拟定。
S型曲线：根据你输入的曲线要素值进行计算曲线。如果你前圆曲线的半径可以调整请你选择。在计算完成后，如果不满足规范要求，请您重新拟定。
三点圆曲线：根据你输入的路线要素值进行计算曲线。如果你要计算主点坐标请你输入交点的桩号。在计算完成后，如果不满足规范要求，请您重新拟定。
凸型曲线：根据你输入的路线偏角与控制的外距或切线长的值进行计算曲线。在计算完成后，如果不满足规范要求，请您重新拟定。


曲线变更



曲线变更

路线有时为避开大量的填挖土方，或为保留重要的建筑物，或为改善弯道部分，以及其它特殊情况，必须变更曲线的一部分者，是测量工作中所难以避免的。下面是常见的几种情况。
曲线变更之变更切线方向：在曲线的起点（或终点）变更曲线方向改设曲线。将新旧转向角进行测量后输入程序就可进行计算，用得到的曲线要素进行新曲线的测设。

在交点处变更切线方向：将新旧转向角进行测量后输入程序就可进行计算，用得到的曲线要素进行新曲线的测设。
改动外矢距：在原曲线的中央变动一定的距离，更改曲线。请您将变动的外距差测量后并输入原曲线的一部分要素进行计算，就可用计算的结果进行敷设新的曲线。
过定点：变更曲线使它过一个定点（切线位置不变）。它的测量设过程如程序所示，在交点P设测站，观测出BPQ的角度和测量出PQ的长度。将观测的值输入到程序中去，计算后可按新的曲线要素进行新曲线的布设。
移动终点：新旧曲线切线相平，起点不动，变动旧曲线与新曲线相连。移动一定的距离，测出其距离，输入到程序中，并选择内移还是外移，进行计算。用得到的曲线要素进行新曲线的测量和放样。
终点不移动：变动旧曲线与新切线连接，终点不向前进。新旧两切线相平等，新切线向外移动一定的距离，在场地测量出其值，输入到程序中进行计算，用得到的曲线要素进行新曲线的测设。


解析交会



解析交会
当你利用测角交会法求求知点的坐标时，如果在求知点上同时与三个或四个点通视有困难，也就是在构成各种交会法有困难时，可以采用单三角形来测定求知点的坐标.
数据的输入不多做介绍了，可以根据图形进行输入，一般不会有什么问题的。但应当指出的是，如果已知点坐标抄错了或者是a角与b角的值抄反了，这些错误在计算中不能被发现，请你在输入完后认真的进行复查一下！

其中γ角是观测的检查角，用于进行检查观测成果的正确性。

随着测距仪和全站仪的使用和普及，测边交会越发显现出它的优点。

已知数据的输入请参照图形(即要保证A、B、C三点要按逆时针方向编号)，注意不要将数据输错了-:)
其中点位较差是用于精度的评定的，请你在使用时注意！

在未知点P上设站，对已知知点ABC进行观测，测量得α角和β角，并利用D点进行γ角观测进行检核。同时要注意按所示图形进行输入数据，（即要保证A、B、C三点要按逆时针方向编号）。
请注意不要将P点选在危险圈内（即通过A、B、C三点的圆周上）。


交点计算



交点计算
用于计算点到直线的距离，可推算出未知点桩号

用于计算两直线的交点坐标。（它可用来计算设计变更时的交点坐标，两条直线是根据现场实际所定，你在直线的两端测出坐标，内业计算出其交点坐标，并根据实际情况选择合适的参数进行设计,还可用于涵洞的长度确定和其桩号的确定）
直线与圆曲线的交点计算
计算直线与圆曲线的交点坐标外，还可计算交点到圆曲线起点的弧长，可推算出交点的桩号


平交路口



平交路口

计算中已知数据的输入：

输入交点O的坐标，坐标请分别输入X，Y的值。
主线的方位角：将在这里输入的是主线的方位角，如193°46′10.2″输入时输193.46102。另如23°38′55″输入23.3855。
T1,T2,R1,R2：如图所示，是计算被交路口圆弧处坐标或放线的依据。
主线路宽，被交路宽：你可以根据实际进行输入。单位是米。
计算米数：用于计算间距长度，你可以根据实际进行确定，如每个桩间距可为1米、2米、3米这三个单选项，可根据需要进行选择。
在计算坐标，偏角法，切线正支距三个复选框内选择要进行计算的类型。

计算和保存

   在你仔细核对后回车或单击"计算"按钮即可进行计算，在右侧的文本框内显示出计算结果。计算完成后，保存按鍵可见，在保存的文件名内输入要保存的文件名即可保存为文本文件。是以追加方式进行保存，不会破坏原文件的。


高程



高程计算

一、功能：
适用于路线高程计算。并可根据你输入的路面的结构层的相关数据进行路面结构层高程的计算。
二、数据录入：
1、请您选择要进行计算的标高类型，是直线还是竖曲线。
1)、直线：请你输入路线的起点桩号、高程，路线的长度和纵坡。
2)、竖曲线：请你输入路线的起点桩号、高程，路线的两个纵坡、切线长及竖曲线的半径。
2、边桩数据：请你输入相应的边桩的距离与横坡。边桩1是与路线中线的平距，如果有中央隔离带请将它的长度扣除，因为它不参与高程的计算。横坡的输入请你参照相应的设计输入。边桩2的距离措的是与边桩1的平距，不是指与路线的中线的距离，请你注意。如果你不输入边桩1的长度将不计算边桩的高程，如果你输入边桩1而没有输入边桩2的距离将不计算边桩2的高程。
3、路面结构层数据：
请您在结构层相关数据内输入你要计算的路面结构层的名称和厚度，在软件中标注的是高差，是相同的意思。结构层的名称将会在计算中出现在结果内和输出到资料中去。如果你不输入将它设置为空的，则其下面的结构层的高程都将不进行计算。
三、计算和保存
在你输入完已知的数据后，单击计算就可进行高程的计算了。
计算完成后，保存按钮可见，单击就可将诸的结果进行保存。它只能保存为CSV格式的文件。它是Microsoft Excel 逗号分隔数值文件。你当然可以用系统的记事本或任一文本编辑器打开。用Microsoft Excel 打开，可以使您更方便的进行数据的整理和打印等工作。


工具



工具

控制桩计算
可以方便用于桥梁及公路上各种构筑物的控制桩的计算，你可以按照图中所示的位置计算出你想要的数据。其中距离d1和d2你可以只添任一个或两个都添，程序会根据你输入的数据做相应的处理。（如可以将它用在带角度圆管涵的一字墙的放样上，效果不错）

极坐标放样计算
通过数据文件进行极坐标放样计算，数据文件的格式为：桩号+空格+X坐标+空格+Y坐标，每个数据一行。如：23000 12.2 22.3。
使用时，首先输入测站点的坐标和后视点坐标。不输入后视坐标可以输入定向方位角。后选择放样数据文件。点击...可以选择要使用的放样的数据文件，或你可在文件输入框内输入要用的放样的数据文件。此时，将在诸结果的表格内显示你选择的数据文件的内容分别显示在相应的位置，如桩号、X、Y坐标。在使用完后，您可以点清空将数据文件进行清空，以方便后面的计算和使用。此时，单击计算并生成放样数据资料，你并可将它保存为文件的形式，以供你使用（可以用记事本打开）！它可以用EXCEL进行读取，进行整理和归纳。方便你存档和使用。
在你没有计算器的时候，而同时你却非要计算一些数据。这时你可以通过坐标正反算进行计算。它可能是测量放样中使用频率很高的一个小程序，当然你可以利用计算器完成同样的功能！
角度的输入方法：如193°46′10.2″输入时输193.46102。又如23°38′55″输入23.3855。(在不特殊说明的情况下角度的输入将全部采用这种方式)
角度的显示方法：如123.4523表示123° 45′ 23″(在不特殊说明的情况下角度的显示将全部采用这种方式)

通过三角形的三个顶点坐标计算三角形各个角和边长值的小程序
圆曲线要素计算
通过圆曲线的已知要素求算其它的要素。
一个科学计算器，使用时请你注意在使用三角函数时，特别注意的是参与计算用的时弧度，不是我们使用的角度。


最终用户许可协议



《公路坐标计算系统》软件许可协议
(本协议受中华人民共和国管辖)

本协议是您(个人或单一实体)与李红卫之间关于《中桩坐标计算程序》软件产品的法律协议，其中包含软件开发商对用户的承诺以及有关升级的说明，请认真阅读。

《公路坐标计算系统》软件包括计算机软件，并可能包括与之相关的媒体和任何的印刷材料，以及联机的或电子文档(下称“软件产品”或“软件”)。一旦安装、复制或以其他方式使用本软件产品，即表示同意接受协议各项条件的约束。如果您不同意协议的条件，则不能获得使用本软件产品的权力。

1.本软件产品受中华人民共和国版权法及国际版权条约和其他知识产权法及条约的保护。用户获得的只是本软件产品的使用权。

2.本软件产品的版权归李红卫所有，受到适用版权法及其他知识产权法及条约的保护。

3.您不得:
* 删除本软件及其他副本上一切关于版权的信息；
* 销售、出租此软件产品的任何部分；
* 制作和提供该软件的注册机及破解程序；
* 对本软件进行反向工程，如反汇编、反编译等。

4.如果您未遵守本协议的任一条款，李红卫有权立即终止本协议，且您必须立即终止使用本软件并销毁本软件产品的所有副本。这项要求对各种拷贝形式有效。

5.零售&OEM版有限担保(不包括从Internet下载的共享标准版和从光盘杂志获得的共享特别版)：在您购买本软件产品之日起90天内(如为PC主机板OEM版，购买日期从您获得OEM版当日算起)，如果您发现软件载体或文件有任何形式的损坏，可到零售商处联系更换(如为OEM版，请到OEM产品销售处联系)。但由于意外事故、操作不当或使用错误所引起的故障，李红卫、零售代理商以及PC主机板销售商不承担任何责任。

6.共享版有限许可(包括从Internet下载的共享标准版和从光盘杂志获得的所有共享版本)：您可以通过Internet传播该软件的共享版。但是，要通过其它途径传播该软件时，必须事先通过李红卫本人许可。

7.注册用户升级担保(包括零售版、OEM版和共享版的注册用户)：零售版和OEM版用户请持软件载体到零售商或OEM产品销售商处进行免费更换或升级，共享版注册用户在升级后不能正常注册时，请将新的注册申请码和旧的注册认证码用电子邮件发送到measuresoft@163.com处免费获得新的注册认证码。

8.使用本软件产品的未注册版本由您自己承担风险，在适用法律允许的最大范围内，李红卫及其代理商在任何情况下不就因使用或不能使用本软件产品的未注册版本所发生的特殊的、意外的、直接或间接的损失承担赔偿责任。即使已事先被告知该损害发生的可能性。

9.使用盗版的本软件产品的一切后果由使用者自己承担。对于使用盗版的本软件产品对使用者的操作系统造成的损害，李红卫及其代理商不承担任何责任。

10.因测量事关重大，因此你在使用本软件进行计算后，请对所计算后的数据你进行相应的校核后，再进行使用，以确保你工程的优质,高速！此软件不包含任何使用保证，不能保证适用或不出故障。作者不对您或别的用户使用此软件所带来的理论上或实际的损失负责。

11.若您对本协议内容有任何疑问，可与李红卫本人 measuresoft@163.com 联系

版权所有 (C) 2002-2004 李红卫 保留所有版权


软件注册



软件注册
 《公路坐标计算系统》是共享软件，您可以自由发布和传播软件，注册用户可以获得我们的技术支持以及其他服务，并且可以免费升级到今后所有的新版本。更重要的是：您的注册还将鼓励我们不断改进和完善这个软件，给大家提供更好的服务，未经注册的软件部分功能受到限制（如曲线部分中桩坐标计算数量受限，不能计算边桩坐标，不能进行边桩坐标的加点计算）。
 当我们收到您的注册费用后，我们将向您发送最新版本的注册码。注册用户可以享受永久使用且没有使用时间、次数及其他功能的限制。在它带给你方便的同时, 希望你能考虑注册这款软件。
附：注册机制:注册是软件根据您现在使用的计算机的硬件得到一个特征码，我们称之为注册申请码，通过一系统的运算后将会得到一个计算结果，它被我们通常称为注册码。在仅在你正确的输入注册码后，软件的所有功能才能使用。这个过程称之为注册。它只能在限定的计算机上使用，即注册过的计算机上使用，这个特性就是我们讲的一机一号。它现在网络上很常见的一种软件保护方式。
 对于企业用户，我们亦提供团体注册优惠。同时，我们也提供给您一个更好的选择，《公路坐标计算系统》企业版，它的功能和注册版是一样的，它采用软件狗的形式进行功能保护，可以随处使用。它将使用更方便一些。

注册用户享受权力
将得到完善的售后服务和技术支持。如果注册用户在系统升级或者系统重新安装后又成为“未注册”的用户，请直接通过Email与我联系（注意：请你在来信中说明您遇到的情况，并告诉我您的汇单号码,原先的注册申请码、注册码，注册时间，注册数量以便我进行查证，因此，请你保存好你的凭证）。如果你在使用本程序中有什么好的建议，好的想法，请告诉我，我会做的更好，我会对有实质性建议者，会免费提供有关的软件！

注册费用
 对于个人用户(不提供发票)，注册费：人民币300元/台。企业版费用:980元，其中包含软件狗一个，光盘一张（程序及相关的说明帮助文件，可以在网页上下载）和发票。

 注册方式
首先，启动公路坐标计算系统后，在帮助菜单内有注册的一项，点击注册，将会看到您的机器码(注册申请码)，并填写注册申请表单（主要为了您的权益,点击下载）。Email给我，我在收到您的注册费用和注册申请Email后，用最快的速度向您发送注册认证邮件。。

 得到注册认证码后，在对话框中点击注册按钮，输入注册码后单击注册按钮即可完成注册。

企业版用户直接在并口内插入软件狗即可使用，没有软件狗将不能运行！(软件需要安装狗的驱动程序)

注册联系Email：MeasureSoft@163.com

银行名称 |  | 帐 户 | 收款人
招商银行 | 招商银行乌鲁木齐分行 (一卡通) | 0991 22378681 | 李红卫
中国农业银行 | 农行乌鲁木齐分行(金穗通宝卡) | 95599 8089 02675 22112 | 李红卫
中国建设银行 | 建设银行乌鲁木齐分行(龙卡) | 4367 4245 4063 0278 002 | 李红卫

技术支持
技术支持网站：测量天地
技术支持QQ:39607719
技术支持邮箱：MeasureSoft@163.com

注：没有邮箱的用户，可到下列网站免费申请：

1、http://mail.163.com
2、http://www.126.com
3、http://www.sohu.com

版权所有(C) 2003-2004 李红卫 , 保留所有权利。 Email： MeasureSoft@163.com


常见问题

公路工程测设伴侣



常见问题

1、如何安装公路工程测设伴侣？
答：系统安安装程序为一个可执行文件，下载直接双击即可自动进行安装，安装程序会自动创建开始菜单程序文件目录及文件名及桌面快捷方式。

2、为何屏幕上只有软件更新窗口，而不见系统主窗口？
答：是因为窗口最小化了，将鼠标移至状态条上的程序图标上单击右键并选择窗口最大化即可。

3、如果硬盘进行格式化后，注册申请码改了怎么办？
答：本软件的注册源是你的硬盘，只要硬盘不更换注册码就不会改变，这种情况下，您只要重新输入申请的注册码即可。
如果您不记得注册码，或更换了新的硬盘，请你来信说明您的情况，并告诉我您的汇单号码、或原先的注册申请码、或注册码等信息以便我进行查证，因此，请你保存好你的凭证）。我会依据新的注册申请码给你重新注册。但是超过一定的次数，我会考虑请你重新付一部分的注册费用！

4、申请注册码后，可以在其它计算机上使用吗？
答：注册码是唯一的，一个注册码只能在一台计算机上使用。如果您想在多台电脑上使用，可本人电话联系。

5、为何运行计算按钮后，报表出现黑屏？
答：这是由于背景色改变造成的，请打单击参数设置按钮，修改基本设置中报表背景色为白色即可。


   注册申请表

请用户填写以下表格申请注册

姓名：
性别：
年龄：
您所处城市：
工作单位：
您的通讯地址：
邮政编码：
电子邮件地址：
  (最好提供邮箱，以后如有注册码更新时好及时发送给您）

联系电话：
传真：
您的注册申请码（必填）：

汇入银行：
（如果使用银行转汇，请填写汇入银行，汇单号码或网上支付的订单号，以便查询）

您对 公路坐标计算系统 的印象或建议：